안드로이드 minSdkVersion

1 개요[ | ]

안드로이드 uses-sdk, 앱을 작동시킬 SDK 버전 지정
안드로이드 minSdkVersion, 최소 SDK 버전
안드로이드 targetSdkVersion, 최소 SDK 버전
  • 앱은 최소 SDK 버전을 만족하는 기기에서만 실행가능
  • 앱마켓에서도 기기가 지원하는 최소 SDK 버전에 맞는 앱만 보여줌

2 예시[ | ]

16px-Crystal_Clear_app_xmag.svg.png AndroidManifest.xml 문서를 참고하십시오.

minSdkVersion을 입력하는 곳은 AndroidManifest.xml이다.

    <uses-sdk
        android:minSdkVersion="14"
        android:targetSdkVersion="17" />
→ targetSdkVersion은 높게[1], minSdkVersion은 낮게...[2]
→ maxSdkVersion라는 옵션도 있지만 생략한다.[3]

3 같이 보기[ | ]

4 주석[ | ]

  1. 향상된 API 기능을 사용할 수 있다. (물론 기기가 높은 버전을 지원할 때)
  2. 그렇다고 너무 낮게 잡으면 그 SDK 버전에서 앱이 작동하게 맞춰주는 일이 어렵다.
  3. SDK가 하위 호환성을 지원하지 않는 상황을 방지하기 위한 것인데... 비교적 최신의 SDK를 사용한다면 고려할 필요가 없겠지...
문서 댓글 ({{ doc_comments.length }})
{{ comment.name }} {{ comment.created | snstime }}